Tag Archives: cloud connector edition

Microsoft Phone System: You’re not set up to use this calling feature

This has come up with a few of my hybrid clients, and it’s not very clear error message so I thought I’d take a minute to post about it.

Issue: You make a call with Microsoft Teams or Skype for Business and instead of reaching the recipient, you hear “You’re not set up to use this calling feature.  Please contact your admin.” from the Diagnostic Announcement Service.

This can arise in a few scenarios.  Scenario 1 is when you’re using Microsoft as you’re telephony provider.  You have Microsoft Phone System licensing and a valid calling plan, but you’re hearing this message.  This typically is due to the user not having a phone number assigned.  If you do have a phone number assigned, try un-assigning it and re-assigning it.

Scenario 2 is the hybrid scenario.  This is where the client is using Cloud Connector Edition (CCE) or OPCH (effectively Lync or a Skype for Business Server on-premises handling hybrid voice).  In this scenario you don’t want a phone number assigned.  I’ve often found that the client has assigned a Domestic Calling Plan or even left Communications Credits enabled as a license for the users.  Disabling the calling plan and/or credits should get the user back to functional.

Oddly enough, I’ve got a client that has most users enabled with communications credits, but a only a small percentage receive the error.  I haven’t worked that out yet past removing the communication credits licensing from their accounts.